티스토리 뷰

* Arista vEOS를 구동 테스트 해보자

   

0. EOS(Extensible Operation System)

> Arista Networks 의 Linux 기반의 Network OS 임, Virtual EOS(vEOS)는 가상머신에서 동작.

   

1. vEOS 다운로드 : Arista 홈페이지 가입 후 다운로드

> Aboot-veos-2.1.0.iso(부트로더) , vEOS-4.14.2F.vmdk(NOS) 다운

https://www.arista.com/en/support/software-download

   

2. 기본 설정 Lab

   

2.1 vEOS VM 설정

> 램 2기가(1기가 가능), Disk(다운받은 *.vmdk 지정), NIC1(관리, VMnet8), NIC2(통신용, VMnet1)

   

> 전원 ON 후 Console 접근 : admin(비밀번호 따로 없음:기본값)

   

2.2 vEOS 기본 설정

> hostname, VLAN생성, L2 Access, SVI 설정, 저장 : 시스코 CLI와 유사

vEOS CLI)

enable

conf t

hostname vEOS

vlan 10

exit

interface ethernet 1

switchport mode access

switchport access vlan 10

no shutdown

interface vlan 10

ip add 10.1.1.1/24

no shut

exit

write mem

   

* MgMt1 로 Telnet 접근하기

vEOS CLI)

enable

conf t

interface management 1

ip add X.X.X.X

no shut

exit

management telnet

no shutdown

username admin secret arista

   

* vEOS 종료하기

vEOS CLI)

bash

$ sudo init 0

   

2.3 IOS 설정

> hostname, VLAN생성, L2 Access, SVI 설정, 저장

IOS CLI)

enable

conf t

hostname IOS

vlan 10

exit

interface fa1/1

switchport mode access

switchport access vlan 10

no shutdown

interface vlan 10

ip add 10.1.1.2 255.255.255.0

no shut

exit

write mem

   

2.4 확인

vEOS CLI)

   

IOS CLI)

   

   

3. vEOS를 이용한 VXLAN 실습

> vEOS에 VXLAN 을 통한 L2 확장과 VXLAN Gateway(VTEP 기능 수행, VNI와 VLAN 맵핑)를 통한 VLAN 네트워크와 통신 확인

   

3.1 vEOS1~3 구성

-

NIC1(MgMt1)

NIC2(Eth1)

NIC3(Eth2)

NIC4(Eth3)

vEOS1

VMnet8, 관리용

VMnet1, IOS 연결

VMnet2, vEOS2 연결

VMnet3, vEOS3 연결

vEOS2

VMnet8, 관리용

VMnet4, PC1 연결

VMnet2, vEOS1 연결

-

vEOS3

VMnet8, 관리용

VMnet5, PC2 연결

VMnet3, vEOS1 연결

-

   

3.2 vEOS1~3 기본 설정

> 호스트네임, 관리용(텔넷 접근용), 텔넷 설정, 계정 설정, 저장

vEOS1

vEOS2

vEOS3

enable

conf t

hostname vEOS1

interface management 1

ip add X.X.X.X

no shut

exit

management telnet

no shutdown

username admin secret arista

write mem

enable

conf t

hostname vEOS2

interface management 1

ip add X.X.X.X

no shut

exit

management telnet

no shutdown

username admin secret arista

write mem

enable

conf t

hostname vEOS3

interface management 1

ip add X.X.X.X

no shut

exit

management telnet

no shutdown

username admin secret arista

write mem

   

3.3 Cisco IOS 구성 & 기본 설정

> 인터페이스 설정, vlan 설정, SVI 설정, NAT 설정

Cisco IOS

hostname IOS

!

vlan 100

!

interface FastEthernet0/0

ip address dhcp

no shut

!

interface FastEthernet1/1

switchport access vlan 100

no shut

!

interface Vlan100

ip address 1.1.100.254 255.255.255.0

no shut

!

access-list 1 permit 1.1.100.0 0.0.0.255

ip nat inside source list 1 interface FastEthernet0/0 overload

!

interface Vlan100

ip nat inside

!

interface FastEthernet0/0

ip nat outside

!

   

3.4 vEOS1~3 구성

> 인터페이스, 라우팅 구성(L3 Network, OSPF, 멀티캐스트)

vEOS1

vEOS2

vEOS3

vlan 100

   

ip routing

ip multicast-routing

   

int e1

sw

sw mode access

sw ac vlan 100

no shut

   

int e2

no sw

ip add 1.1.12.1/24

ip pim sparse-mode

no shut

   

int e3

no sw

ip add 1.1.13.1/24

ip pim sparse-mode

no shut

   

int lo 0

ip add 1.1.1.1/32

no shut

   

ip pim rp-address 1.1.1.1

   

router ospf 1

router-id 1.1.1.1

passive-interface default

no passive-interface ethernet 2

no passive-interface ethernet 3

network 0.0.0.0/0 area 0.0.0.0

vlan 101

   

ip routing

ip multicast-routing

   

int e1

sw ac vlan 101

no shut

   

int e2

no sw

ip add 1.1.12.2/24

ip pim sparse-mode

no shut

   

int lo 0

ip add 1.1.1.2/32

no shut

   

ip pim rp-address 1.1.1.1

   

router ospf 1

router-id 1.1.1.2

passive-interface default

no passive-interface ethernet 2

network 0.0.0.0/0 area 0.0.0.0

vlan 100

   

ip routing

ip multicast-routing

   

int e1

sw ac vlan 100

no shut

   

int e2

no sw

ip add 1.1.13.3/24

ip pim sparse-mode

no shut

   

int lo 0

ip add 1.1.1.3/32

no shut

   

ip pim rp-address 1.1.1.1

   

router ospf 1

router-id 1.1.1.3

passive-interface default

no passive-interface ethernet 2

network 0.0.0.0/0 area 0.0.0.0

   

   

3.5 PC1,2 구성

> WinXP1,2에 IP할당 및 vEOS2,3 에서 mac 정보 확인

PC1, Winxp 의 IP정보

   

3.6 vEOS1~3에 VXLAN 설정 후 통신 확인

> 각각 VXLAN 설정

vEOS1

vEOS2

vEOS3

int vxlan 1

vxlan multicast-group 239.1.1.1

vxlan source-interface lo0

vxlan udp-port 4789

vxlan vlan 100 vni 100

no shut

int vxlan 1

vxlan multicast-group 239.1.1.1

vxlan source-interface lo0

vxlan udp-port 4789

vxlan vlan 101 vni 100

no shut

int vxlan 1

vxlan multicast-group 239.1.1.1

vxlan source-interface lo0

vxlan udp-port 4789

vxlan vlan 100 vni 100

no shut

   

> VXLAN 설정 후 PC1(Winxp)에서 PC2와 VXLAN 통한 통신과, 외부 인터넷(NAT 적용) 통신 확인

   

> VXLAN 연결 VTEP 정보 확인

   

> VXLAN 연결 VTEP 정보 확인

   

> VXLAN을 통한 MAC 정보 학습

   

3.7 VXLAN 패킷 분석

[1] PC1(1.1.100.101) -> 인터넷(168.126.63.1)로 Ping : vEOS1---(패킷캡쳐)---vEOS2

> UDP4789로 감싸있으며, vEOS2(VTEP)을 통하여 VNI가 100이 할당되어 빠져나감

[2] 인터넷(168.126.63.1) -> PC1(1.1.100.101) 로 Ping응답 : vEOS1---(패킷캡쳐)---vEOS2

> 응답하는 패킷이며, vEOS1(VTEP)을 통하여 VNI 역시 100이 할당되어 돌아옴

   

   

* 참고 링크

http://theplmingspace.tistory.com/737 : vEOS 구동

http://ryusstory.tistory.com/282 : vEOS 구동

http://www.slideshare.net/KwonSunBae/vxlan-deep-dive-session-rev05-final : VXLAN 참고

http://brezular.com/2014/10/03/arista-veos-on-gns3/ : vEOS 구동

http://www.arista.com/docs/Manuals/ConfigGuide.pdf : User Manual

http://theplmingspace.tistory.com/683 : VXLAN이론1 (추천)

http://theplmingspace.tistory.com/688 : VXLAN이론2 (추천)

http://theplmingspace.tistory.com/786 : vEOS로 VXLAN구현 (추천)

댓글
댓글쓰기 폼
공지사항
Total
374,686
Today
132
Yesterday
142
링크
«   2018/10   »
  1 2 3 4 5 6
7 8 9 10 11 12 13
14 15 16 17 18 19 20
21 22 23 24 25 26 27
28 29 30 31      
글 보관함